VATSIM - DDoS attacks affecting VATSIM availability – Incident details

Experiencing partially degraded performance

DDoS attacks affecting VATSIM availability

Monitoring
Degraded performance
Started 2 days ago

Affected

Web Services

Operational from 3:11 PM to 3:11 PM, Degraded performance from 3:11 PM to 12:00 AM

Connect

Operational from 3:11 PM to 3:11 PM, Degraded performance from 3:11 PM to 12:00 AM

FSD

Operational from 3:11 PM to 3:11 PM, Degraded performance from 3:11 PM to 12:00 AM

USA West

Operational from 3:11 PM to 3:11 PM, Degraded performance from 3:11 PM to 12:00 AM

USA East 1

Operational from 3:11 PM to 3:11 PM, Degraded performance from 3:11 PM to 12:00 AM

USA East 2

Operational from 3:11 PM to 3:11 PM, Degraded performance from 3:11 PM to 12:00 AM

Updates
  • Update
    UTC
    Update

    Around 6z this morning, another DDoS attack began targeting our infrastructure, resulting in servers being blackholed again. Degraded performance or loss of connectivity should be expected whilst the attack is ongoing. We're continuing to investigate mitigation methods.

  • Monitoring
    UTC
    Monitoring

    The attack has reduced for the past few hours. However, it may resume at any moment depending on the whims of the attacker.

    We will continue to monitor.

  • Identified
    UTC
    Identified

    Several of our services have been experiencing a wide-scale DDoS attack. This means many many computers around the world are sending network traffic to VATSIM in order to overwhelm our systems.

    Due to the size of this attack (we've seen it hit upwards of 30 Mpps, for those who know what that means), our infrastructure providers have to temporarily "blackhole" all traffic in/out of VATSIM, causing multiple servers to appear "down."

    We're looking into ways to further mitigate this.

  • Investigating
    UTC
    Investigating
    We are currently investigating this incident.