FSD Connectivity Issues

Major Incident UK-2 GERMANY-2 Dataserver USA-WEST USA-EAST UK-1 SINGAPORE GERMANY CANADA Network Services
26 minutes

Update

Resolved

Our Engineering team has confirmed that all issues are now resolved. All systems should be operating normally. We apologize for any inconvenience, and thank you for your patience.

March 31th, 2020 at 05:01 UTC
Monitoring

Our Engineering team has confirmed that all issues are now resolved. All systems should be operating normally. We apologize for any inconvenience, and thank you for your patience.

March 31th, 2020 at 04:59 UTC
Issue

Our Engineering team is investigating an issue affecting FSD connections across all regions. During this time, users may experience errors or delays while connecting to or utilizing the network.

We apologize for the inconvenience and will share an update once we have more information.

March 31th, 2020 at 04:37 UTC