Everything is operational
Database Slowness - We are investigating database connectivity issues. This is causing some users to be unable to connect to the network and web services. We will update this incident as progress is made
Resolved
We are seeing all systems recover at this time. We will continue to monitor through the day
Sat, 01 Apr 2023 14:39:38 +0000
Monitoring
We have made some back end changes to assist and things appear to be recovering. We are still monitoring.
Sat, 01 Apr 2023 13:46:14 +0000