Mobile Device Degraded Performance

Minor Incident Forums Web Services
15 hours, 35 minutes

Update

Resolved

The issue has been resolved.

April 14th, 2020 at 01:04 UTC
Issue

We are aware of issues with the new forum not displaying correctly on mobile and computer devices using Safari. We are working on a fix at this time and thank you for your patience.

April 13th, 2020 at 09:31 UTC