FSD Connection Issues

Major Incident USA-EAST UK-1 SINGAPORE GERMANY Network Services
1 hour, 3 minutes

Update

Resolved

Issues with FSD connections have now been resolved. We apologize for any inconveniences.

May 3th, 2020 at 02:23 UTC
Monitoring

The issue has now been resolved. We will continue to monitor the situation.

May 3th, 2020 at 02:05 UTC
Issue

We are aware of some issues with connections to FSD and our team are currently investigating. We will post an update as soon as we have new information.

May 3th, 2020 at 01:26 UTC