GERMANY-2 Connections Limited from 2020-05-22 19:00 UTC to 2020-05-23 15:30 UTC

Scheduled Maintenance GERMANY-2 Network Services
20 hours, 30 minutes

Update

Update

Connections to the GERMANY-2 server are now permitted again. Many thanks for your patience.

May 23th, 2020 at 15:45 UTC
Update

New connections to the GERMANY-2 server have now been limited. Please select another server if you are unable to connect to this one.

Thanks for your understanding!

May 22th, 2020 at 19:06 UTC
Scheduled

New connections to the GERMANY-2 server will shortly be disabled in order to allow us to restart the server later on to get back the [Mod - Happy Thoughts] voice ATISs from connections to this server without affecting the experience of those connected to the network.

Those already connected to this server can complete their flights/control sessions without being affected as this cap only affects new connections. Please select another server in the meantime.

We apologize for any inconvenience.

May 22th, 2020 at 18:39 UTC