Server Issues
Incident Report for VATSIM Network
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 21:48 UTC
Investigating
We are investigating reports of connection issues with both the USA West and Singapore servers. Members who have issues are suggested to use an alternative server until a fix is in place.
Posted Jul 12, 2021 - 10:58 UTC
This incident affected: FSD Servers (Singapore, USA West).